Redirect Weirdness

Somethin' on dis here forum site dat just ain't kosher wit you? Think of some new dope-ass color scheme? Gots an idea fo' a sweet new forum? Den dis here be da place to post all o' dat shiznat! Word is bond.

Moderator: Gomer

Post Reply
User avatar
Jobu
Voodoo Deity
Posts: 83
Joined: Tue Jul 24, 2001 9:00 pm

Redirect Weirdness

Post by Jobu » Mon Nov 05, 2018 9:49 pm

Not sure if anyone else was noticing this, but today I started seeing the following error whenever I tried to create/edit a post:
General Error
Tried to redirect to potentially insecure url.
I'm not sure why this started showing up all of a sudden, as I hadn't changed anything since the update last month. Google searches were relatively fruitless, so I had to dig in and start dicking with server settings. After a little bit of trial and error, it looks like everything is working again. I'm not 100% sure why what I changed fixes the problem, but I'm just going to roll with it and see what happens.

Let me know if you see anything weird, or have trouble performing any typical actions (creating posts, editing posts, sending PMs, etc.). One thing - I tweaked the cookie settings, so you may need to clear those out for this site if you're having trouble logging in/staying logged in. Try that if you run into any problems, and if that doesn't help let me know.

User avatar
Gomer
Moderator
Posts: 3663
Joined: Thu Oct 04, 2001 7:31 pm
Location: Zimbabwe (Rhodesia)

Re: Redirect Weirdness

Post by Gomer » Tue Nov 06, 2018 8:58 am

One observation I'd like to share this morning - I've had to clear cookies (just for this site) and do a hard refresh on every browser I've used since last night to manage to stay logged in, so you all may have to do the same. I really hate that as a solution but it seems to be the only thing that works at the moment. Sorry. :cry:

Asshander
Disciple of Shaft
Posts: 2945
Joined: Thu Oct 04, 2001 10:04 pm
Location: Berlin

Re: Redirect Weirdness

Post by Asshander » Tue Nov 06, 2018 12:21 pm

I had it happen once yesterday, but it was just the once so I didn't think much of it. I did notice I was logged out today, but everything seems fine since. ¯\_(ツ)_/¯

User avatar
Hellraiser
Disciple of Shaft
Posts: 839
Joined: Fri Aug 30, 2002 4:21 pm

Re: Redirect Weirdness

Post by Hellraiser » Tue Nov 06, 2018 4:39 pm

Despite not being able to log in earlier today. It seems to be working fine now.

Asshander
Disciple of Shaft
Posts: 2945
Joined: Thu Oct 04, 2001 10:04 pm
Location: Berlin

Re: Redirect Weirdness

Post by Asshander » Mon Nov 12, 2018 2:54 pm

I'm seeing the login weirdness. I can login with an incognito tab, but not in standard. This is on my Chromebook, though I've had the same problem on my phone. And this is all after clearing cookies and refreshing, etc.

I'll keep kicking, but it seems like things aren't playing nicely.

User avatar
Jobu
Voodoo Deity
Posts: 83
Joined: Tue Jul 24, 2001 9:00 pm

Re: Redirect Weirdness

Post by Jobu » Mon Nov 12, 2018 4:26 pm

So you're not getting an error, but when you login effectively nothing happens? It just takes you back to the home page and you're not logged in? I've seen this sporadically since "fixing" the error message.

Edit: I just updated some settings and actually renamed the cookies that get created (something I should've done last time). Everyone will have to log in again, however I haven't had any problems on every browser I've tried, both on desktop and mobile. /fingers crossed

Asshander
Disciple of Shaft
Posts: 2945
Joined: Thu Oct 04, 2001 10:04 pm
Location: Berlin

Re: Redirect Weirdness

Post by Asshander » Mon Nov 19, 2018 12:31 pm

That seems to have done the trick. Huzzah!

Post Reply